Change to documentation of primitive shapes

Let the developers know what you think of the software and what can be done to either improve the CFDG language or the Context Free program.

Moderators: chris, MtnViewMark, MtnViewJohn

Post Reply
User avatar
Monkstone
Posts: 14
Joined: Fri Jul 03, 2009 10:40 pm
Location: Pembrokeshire, UK
Contact:

Change to documentation of primitive shapes

Post by Monkstone » Mon Aug 24, 2009 11:26 pm

I think that the coordinates of the equilateral triangle should be (0, 1/sqrt(3)), (-0.5, -sqrt(3)/6), (0.5, -sqrt(3)/6). I only came across this because it caused me a bit of pain when implementing the triangle in Jeremy Ashkenas context free DSL (in ruby processing). It looks quite a promising effort by Jeremy. One big plus point is that he has created a control panel and you can alter the random seed interactively. Currently more suitable for hackers than artists though.

User avatar
MtnViewJohn
Site Admin
Posts: 844
Joined: Fri May 06, 2005 2:26 pm
Location: Mountain View, California
Contact:

Post by MtnViewJohn » Tue Aug 25, 2009 8:21 am

You're right. That image was created by user pakin. If he is following the cfdg forums then maybe he will update the diagram with the correct triangle coordinates.

But, it's a wiki. Anyone can fix it.

http://www.contextfreeart.org/mediawiki ... inates.png

User avatar
MtnViewJohn
Site Admin
Posts: 844
Joined: Fri May 06, 2005 2:26 pm
Location: Mountain View, California
Contact:

Post by MtnViewJohn » Wed Aug 26, 2009 7:36 am

You can close your drawing applications. Pakin is going to fix it soon.

User avatar
pakin
Posts: 40
Joined: Sat Apr 21, 2007 8:59 pm
Location: United States
Contact:

Post by pakin » Wed Aug 26, 2009 9:07 pm

MtnViewJohn wrote:You can close your drawing applications. Pakin is going to fix it soon.
Done. The result looks fine on the Primitive Shapes page and as a high-resolution image but has corrupted colors as a low-resolution image. Any idea what's up with that?

User avatar
MtnViewJohn
Site Admin
Posts: 844
Joined: Fri May 06, 2005 2:26 pm
Location: Mountain View, California
Contact:

Post by MtnViewJohn » Wed Aug 26, 2009 9:12 pm

We're running an old version of Mediawiki. It's probably a bug. Upgrading the wiki and the forums is on my todo list.

User avatar
kipling
Posts: 91
Joined: Wed Jun 18, 2008 2:36 am

mediawiki

Post by kipling » Thu Aug 27, 2009 1:23 am

Looks like Mediawiki suffers Protanopia

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests